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1. Feed Button LED Status issues

1.1 Red flashing quickly (twice per second)

Reason 1：Paper Shortage:

Straightly and smoothly insert label, printer will automatically feed it. Hold Feed Button until the blue light

flashes 2 times for label calibration.

Reason 2：Label paper detection error, paper state is determined by the printer as no paper state:

(1)Transparent Label with black mark？

Learn the label with black mark:

Open the cover and put the label in, then close the cover. Hold the Feed button til the blue light flashes 3

times, then release the Feed button.

Video(Learn Black Mark Labels): https://www.youtube.com/watch?v=1F26Q3EvT1U&list=PLkFsmMLq8_heJ
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Wd4-lKWMfWz0Dj1a-M6y&index=4(2)Gap label (Includes round / circular label)？

Run the Sensor Calibration:

Open the cover and put the label in, then close the cover. Hold the Feed button til the blue light flashes 2

times, then release the Feed button.

Video(Learn Gap Labels): https://www.youtube.com/watch?v=vj2GJkR6yaw&list=PLkFsmMLq8_heJWd4-lK

WMfWz0Dj1a-M6y&index=3

Still flashing red lights？

Contact us:

Tel:+1 833-940-3818

Office Hours: Mon-Fri 9AM-5PM(US EST)

Email: support@labelife.net

Could you please take some video of the problem for us to check?

We will provide faster and better solutions for you.
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1.2 Click print, the label backwards and exits the roller

The discrimination threshold of the front sensor can change during daily use. We recommend: upgrade

firmware to solve the problem.

(1)Firmware upgrades with mobile device

Click Firmware Upgrade in the App to check whether it is the latest firmware version

(2)Firmware upgrades with computer

Download Labelife PC Software and complete install:

https://www.labelife.net/#/download

Connect the printer to computer via USB cable. Go Help -> Firmware, click Firmware Upgrade. If Labelife is

no response after Firmware Upgrade, please wait a moment: the network speed may be slow. After

upgrading the firmware, please restart the printer and try to print again to check whether it can print

properly.
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1.3 Red flashing slowly (once per second)

Reason：Cover is not closed:

Operation: Please install the label paper, check whether the printer cover is tightly closed. When the cover is

closed, the indicator light will always be blue, that is, the print ready state, you can carry out normal printing.

1.4 Solid red

Printer head is over-heated:

Leave the printer alone for 15-30 minutes to resume printing.

1.5 Click Print, the printer blinks blue

Reason: Paper jam

Operation: Turn off the printer and open the top cover of the printer to remove the label paper. The label will
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be intact again loaded, close the cover. Turn on the printer, the indicator light is always blue, the printer can

print normally.

Note: If there is any adhesive residue, please clean the print head before loading the label paper.

Video(Cleaning the print head): https://youtu.be/P2uwHWfHZBY

(2)Label detection error:

Measure the label length and width Dimensions to check that they match the dimensions of the labels

created and sent to printer from your mobile device or computer.

1.6 Blue flashing quickly

Reason：Wrong media tracking

Operation: Check your label type

(1)Gap Label？

Open the cover and insert the label, then close the cover. Press and hold the paper feed button until the blue

light blinks 2 times, then release the paper feed button and calibrate the paper to finish.

Video(Learn Gap Labels): https://youtu.be/zrbjjwWpFV4

(2)Label with black mark？

Open the cover and insert the label, then close the cover. Press and hold the paper feed button until the blue

light blinks 3 times, then release the paper feed button and calibrate the paper to finish.

https://youtu.be/P2uwHWfHZBY
https://youtu.be/zrbjjwWpFV4
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Video(Learn Black Mark Labels): https://youtu.be/OuCeCyjlbK4

(3) Continuous paper？

Straightly and smoothly insert paper, printer will automatically feed it and feed 300mm (Printer factory

defaults is gap label. Printer will feed 300mm to detect gap position.). Set the paper type to continuous on

your mobile device or computer and print the first task. The parameter of printer paper type will be

overridden to continuous paper.

1.7 Click print, the printer lights purple and keeps going back and

forth.

Reason:The probability is that the computer has placed a print job that the printer cannot recognize and

parse.

Operation: 1、Turn off the printer,Remove the printer USB cable, and turn on the printer. To restore factory

settings: Hold the Feed Button til the blue light blinks 4 times,then release.

2、Clear the print job on the computer or mobile device. Check the printer model when clicking Print:

confirm that it is the current printer model.

Video(restore the factory settings): https://youtu.be/4APXUAhG4_g

https://youtu.be/OuCeCyjlbK4
https://youtu.be/4APXUAhG4_g
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2. Printing issues

2.1 Printing blank labels

1.Please ensure your labels are "Direct Thermal" labels and properly loaded (The print side is facing up).

2.Ensure you are using the factory-supplied(24V 2.5A) power adapter

Type Ⅰ Type Ⅱ

3.Please try to restore the factory settings and restart the printer several times: When the printer is in

standby, press and hold the feed button for about 10 seconds after the blue light blinks 4 times，release the

feed button.

Video(restore the factory settings): https://youtu.be/4APXUAhG4_g

4.Try to print out test page

-> Press the Feed Button and hold it until blue light flashes 1 time, then release. Printer will print a test page.

If test print looks good, please try to print your label again.

Video(Print out test page): https://youtu.be/3J_HfVoYa_w

https://youtu.be/4APXUAhG4_g
https://youtu.be/3J_HfVoYa_w
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Problem not solved？Try to reset the printer parameters

(1)Printing from computer

①Windows

1.Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option". Reset the printer parameters as shown

below

2.Try to print the Labels-Sample PDF, you can get it from pm245.labelife.cc-> Manuals

②macOS

1.Open a desired file, File->Print->Page Option, Reset the printer parameters as shown below
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2.Try to print the Labels-Sample PDF, you can get it from pm245.labelife.cc-> Manuals

③Not your computer system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email: support@labelife.net
Could you please take some video of the problem for us to check? We will provide faster and better solutions for you.

(2)Printing from mobile device

1.Please upgrade Labelife APP to the latest version! Reset the printer parameters as shown below

2.Try to print the Labels-Sample PDF, you can get it from home page
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Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email: support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide a photo of the adapter?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅴ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
ⅵ.Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

2.2 Barely see a shadow of anything printed

1.Clean print head:

Turn off the printer. Open cover and use the alcohol pads to wipe the print head and roller clean. (Any 75%

Alcohol pad would work.) Allow 2-3 minutes for components to dry, then close the cover and turn label

printer back on.

Video(Cleaning the print head): https://youtu.be/P2uwHWfHZBY

2.Ensure you are using the factory-supplied(24V 2.5A) power adapter

Type Ⅰ Type Ⅱ

3.Try to print out test page

-> Press the Feed Button and hold it until blue light flashes 1 time, then release. Printer will print a test page.

If test print looks good, please try to print your label again.

https://youtu.be/P2uwHWfHZBY


14

Video(Print out test page): https://youtu.be/3J_HfVoYa_w

Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email: support@labelife.net

(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the adaptor?
(3)Could you please provide the model and system version of your computer or mobile device?
(4)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(5)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(6)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

2.3 Poor printing quality / ink is blurry

1.Clean print head:

Turn off the printer. Open cover and use the alcohol pads to wipe the print head and roller clean. (Any 75%

Alcohol pad would work.) Allow 2-3 minutes for components to dry, then close the cover and turn label

printer back on.

Video(Cleaning the print head): https://youtu.be/P2uwHWfHZBY

2.Please reduce the print speed and increase density

(1)Printing from computer

①Windows

Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option".

You can change the Speed and Density of your printing (Larger number means faster print speeds and

higher Density)

https://youtu.be/3J_HfVoYa_w
https://youtu.be/P2uwHWfHZBY
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②macOS

Open a desired file, File->Print->Page Option. You can change the Speed and Density of your printing

(Larger number means faster print speeds and higher Density)
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③Not your computer system?

Contact us:Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

(2)Printing from mobile device

Open Labelife -> Click Print. You can change the Speed and Density of your printing (Larger number means

faster print speeds and higher Density)
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Problem not solved？

Contact us:Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

2.4 Barcode or QR code would not scan

1.For DHL: Try to reduce the print density to 5, reduce the print speed to 2, and then try to print your label

again.

2.For others：Try to reduce the print density to 6, reduce the print speed to 3, and then try to print your label

again.

How to Reduce Print Speed and Density？

(1)Printing from computer

①Windows

Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option". You can change the Speed and Density

of your printing (Smaller number means slower print speeds and lower Density)
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②macOS

Open a desired file, File->Print->Page Option. You can change the Speed and Density of your printing

(Smaller number means slower print speeds and lower Density)

③Not your computer system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
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ⅵ.Could you please provide a photo of your printer's test page? (How to get printer's test page? -> Press the Feed Button and
hold it until blue light flashes 1 time, then release. Printer will print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

(2)Printing from mobile device

Open Labelife -> Click Print.

You can change the Speed and Density of your printing (Smaller number means slower print speeds and

lower Density)

Problem not solved？

Contact us:Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
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ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

2.5 Kept getting paper jam error notifications from mobile device

1.Clean print head: Turn off the printer. Open cover and use the alcohol pads to wipe the print head and

roller clean. (Any 75% Alcohol pad would work.) Allow 2-3 minutes for components to dry, then close the

cover and turn label printer back on.

Video(Cleaning the print head): https://youtu.be/P2uwHWfHZBY

2.Label size detection error:

Measure the label length and width Dimensions to check that they match the dimensions of the labels

created and sent to printer from your mobile device or computer.

3.Learn the label:

(1)with gap:

Open the cover and insert the label, then close the cover. Press and hold the paper feed button until the blue

light blinks 2 times, then release the paper feed button and calibrate the paper to finish.

Video(Learn Gap Labels): https://youtu.be/zrbjjwWpFV4

(2)with black mark:

Open the cover and insert the label, then close the cover. Press and hold the paper feed button until the blue

light blinks 3 times, then release the paper feed button and calibrate the paper to finish.

Video(Learn Black Mark Labels): https://youtu.be/OuCeCyjlbK4

4. Please reinstall the Labelife App and reconnect the printer.

Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide the model and system version of your mobile device?
ⅲ.Could you please provide Screenshots or videos of the App status and settings?

https://youtu.be/P2uwHWfHZBY
https://youtu.be/zrbjjwWpFV4
https://youtu.be/OuCeCyjlbK4
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ⅳ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅴCould you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
ⅵ.Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

2.6 Print halfway or the first third of the label then stop or jam up

1.Ensure power connection

A. Ensure the wall plug has electricity by plugging another device into that same plug.

B. Follow the power cable to the adapter and check that the cable that goes to printer is plugged in all the

way into the power adapter.

C. Ensure the plug that goes into printer is fully inserted.

2. Please check whether the adapter works normally during printing. (Observe whether the indicator light

will go out.) And if you have another 24V 2.5A adapter, please try to use it to see if it can solve the problem.

Type Ⅰ Type Ⅱ

3.Try to reduce the print density to 6, reduce the print speed to 3, and then try to print your label again.

How to Reduce Print Speed and Density？

(1)Printing from computer

①Windows

Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option". You can change the Speed and Density
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of your printing (Smaller number means slower print speeds and lower Density)

②macOS

Open a desired file, File->Print->Printer Option. You can change the Speed and Density of your printing

(Smaller number means slower print speeds and lower Density)

③Not your computer system?
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Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?(How to get printer's test page? -> Press the Feed Button and
hold it until blue light flashes once, then release. Printer will print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

(2)Printing from mobile device

Open Labelife -> Click Print.

You can change the Speed and Density of your printing (Smaller number means slower print speeds and

lower Density)

Problem not solved？

Contact us:Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
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Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

2.7 Prints only the left/right half of the label

1. Cover is not completely closed

Operation：Firmly press the cover to confirm that it has been completely closed.

2.Loose print head socket

Please check if the print head socket is tightly plugged

2.8 Doesn't calibrate properly / labels are cut off / Skipping labels

1.Try to restore the factory settings: When the printer is in standby, press and hold the feed button for about

10 seconds after the blue light flashes 4 times, release the feed button.

Video(restore the factory settings): https://youtu.be/4APXUAhG4_g

2.Learn the label:

(1)with gap:

Open the cover and put the label in, then close the cover. Hold the Feed button til the blue light flashes 2

https://youtu.be/4APXUAhG4_g
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times, then release the Feed button.

Video(Learn Gap Labels):

https://www.youtube.com/watch?v=vj2GJkR6yaw&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index

=3

(2)with black mark:

Open the cover and put the label in, then close the cover. Hold the Feed button til the blue light flashes 3

times, then release the Feed button.

Video(Learn Black Mark Labels):

https://www.youtube.com/watch?v=1F26Q3EvT1U&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&ind

ex=4

3.Make sure your printer's print size is the same as the label's size:

Measure the label length and width Dimensions to check that they match the dimensions of the labels

created and sent to printer from your mobile device or computer.

4.Try to reduce the print speed to 3, and then try to print your label again.

How to Reduce Print Speed and Density？

(1)Printing from computer

①Windows

Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option". You can change the Speed and Density

of your printing (Smaller number means slower print speeds and lower Density)
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②macOS

Open a desired file, File->Print->Page Option. You can change the Speed and Density of your printing

(Smaller number means slower print speeds and lower Density)



27

③Not your computer system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?(How to get printer's test page? -> Press the Feed Button and
hold it until blue light flashes once, then release. Printer will print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

(2)Printing from mobile device

Open Labelife -> Click Print.

You can change the Speed and Density of your printing (Smaller number means slower print speeds and

lower Density)

Problem not solved？
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Contact us:Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

2.9 It wouldn't feed the label

1.Clean Sensors: Turn off the printer. Open cover and use the alcohol pads to wipe the print head, roller and

sensors clean. (Any 75% Alcohol pad would work.) Allow 2-3 minutes for components to dry, then close the

cover and turn label printer back on.

Video(Cleaning the print head): https://youtu.be/P2uwHWfHZBY

2.Manually turn the Paper Feed Roller to see if it can be turned.

3.Ensure you are using the factory-supplied(24V 2.5A) power adapter

Type Ⅰ Type Ⅱ

4.Try to print out test page

-> Press the Feed Button and hold it until blue light flashes once, then release. Printer will print a test page. If

test print looks good, please try to print your label again.

Video(Print out test page): https://youtu.be/3J_HfVoYa_w

https://youtu.be/P2uwHWfHZBY
https://youtu.be/3J_HfVoYa_w
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Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(3)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(4)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

2.10 Click print, the printer keeps going back and forth.

Reason:The probability is that the computer or mobile device has placed a print job that the printer cannot

recognize and parse.

Operation：Turn off the printer, remove the printer cable, and turn on the printer. To restore factory settings:

Hold the Feed Button til the blue light blinks 4 times,then release.

Video(restore the factory settings): https://youtu.be/4APXUAhG4_g

Clear the print job on the computer or mobile device. Check the printer model when clicking Print: confirm

that it is the current printer model.

Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(3)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(4)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

https://youtu.be/4APXUAhG4_g


30

2.11 Prints too small

(1)Printing from computer with Driver ?

①Windows

Video(Win10：Crop Pages With Adobe): https://youtu.be/UKgOdE47kks

Video(Win10：Take A Snapshot With Adobe): https://youtu.be/zECjUrwSab0

②macOS

Video(Mac：Crop Pages With Adobe): https://youtu.be/ldaqRl0uUCs

Video(Take A Snapshot With Adobe): https://youtu.be/ol0VU6ZVy6s

③Chrome

Video：https://www.youtube.com/watch?v=8pJdxf-Xuhs&t=3s

③Not your computer system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?(How to get printer's test page? -> Press the Feed Button and
hold it until blue light flashes once, then release. Printer will print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(3)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(4)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

https://youtu.be/UKgOdE47kks
https://youtu.be/zECjUrwSab0
https://youtu.be/ldaqRl0uUCs
https://youtu.be/ol0VU6ZVy6s
https://www.youtube.com/watch?v=8pJdxf-Xuhs&t=3s
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2.12 Doesn't line up and prints crooked / Doesn't align well / Never

stays center

2.12.1 Round / Circular labels?

①Windows

Refer to the video below.

https://www.youtube.com/watch?v=ThHr7eZRzCI&list=PLVhZS7j4F8-LKpWhPw3zTjLVInpBhMlqq&index=9

②macOS

Refer to the video below.

https://www.youtube.com/watch?v=hAEvvwq_OYk&list=PLVhZS7j4F8-LKpWhPw3zTjLVInpBhMlqq&index=8

③Labelife PC and macOS

④mobile device
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⑤Not your system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?(How to get printer's test page? -> Press the Feed Button and
hold it until blue light flashes once, then release. Printer will print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

2.12.2 Upper and lower misalignment?

1.Learn the label:

(1)with gap:

Open the cover and put the label in, then close the cover. Hold the Feed button til the blue light flashes 2

times, then release the Feed button.

Video(Learn Gap Labels):

https://www.youtube.com/watch?v=vj2GJkR6yaw&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index

https://www.youtube.com/watch?v=vj2GJkR6yaw&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index=3
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=3

(2)with black mark:

Open the cover and put the label in, then close the cover. Hold the Feed button til the blue light flashes 3

times, then release the Feed button.

Video(Learn Black Mark Labels):

https://www.youtube.com/watch?v=1F26Q3EvT1U&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&inde

x=4

2.Try to reduce the print speed to 3, and then try to print your label again.

How to Reduce Print Speed and Density？

(1)Printing from computer

①Windows

Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option". You can change the Speed and Density

of your printing (Smaller number means slower print speeds and lower Density)

https://www.youtube.com/watch?v=vj2GJkR6yaw&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index=3
https://www.youtube.com/watch?v=vj2GJkR6yaw&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index=3
https://www.youtube.com/watch?v=1F26Q3EvT1U&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index=4
https://www.youtube.com/watch?v=1F26Q3EvT1U&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index=4
https://www.youtube.com/watch?v=1F26Q3EvT1U&list=PLkFsmMLq8_heJWd4-lKWMfWz0Dj1a-M6y&index=4
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②macOS

Open a desired file, File->Print->Page Option. You can change the Speed and Density of your printing

(Smaller number means slower print speeds and lower Density)

③Not your computer system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
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ⅵ.Could you please provide a photo of your printer's test page?(How to get printer's test page? -> Press the Feed Button and
hold it until blue light flashes once, then release. Printer will print a test page.)
ⅶ.Your order number and the date and platform of purchase.We will provide faster and better solutions for you.

(2)Printing from mobile device

Open Labelife -> Click Print.

You can change the Speed and Density of your printing (Smaller number means slower print speeds and

lower Density)

Problem not solved？

Contact us:Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
ⅰ.Could you please take some video of the problem for us to check?
ⅱ.Could you please provide Screenshots or videos of the print darkness and speed settings?
ⅲ.Could you please provide the model and system version of your computer or mobile device?
ⅳ.Could you please provide the file you are using to print for testing?
ⅴ.Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
ⅵ.Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
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2.12.3 left-right misalignment?

1.Make sure the adjustable paper guides are clamped to the labels.

Video(How to adjust paper

guides):https://www.youtube.com/watch?v=kxhWFtkXj84&list=PLkFsmMLq8_heSe0V4VqK42qh6XlFrgB68

2.Try to reset the printer parameters

(1)Printing from computer

①Windows

1.Go to "Control panel": Click on "This PC”, input "Control panel"-> "Devices and Printers" -> Right click on

your Label Printer -> choose "Printer Preferences" -> Go to "Option". Reset the printer parameters as shown

below

2.Try to print the Labels-Sample PDF, you can get it from pm245.labelife.cc-> Manuals
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②macOS

1.Open a desired file, File->Print->Page Option, Reset the printer parameters as shown below

2.Try to print the Labels-Sample PDF, you can get it from pm245.labelife.cc-> Manuals

③Not your computer system?

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email: support@labelife.net
Could you please take some video of the problem for us to check? We will provide faster and better solutions for you.
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(2)Printing from mobile device

1.Please upgrade Labelife APP to the latest version! Reset the printer parameters as shown below

2.Try to print the Labels-Sample PDF, you can get it from home page

Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(3)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(4)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

3. Bluetooth Troubleshooting

3.1 Bluetooth disconnects frequently
Contact us for more
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
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(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(3)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(4)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

3.2 Click Print, Bluetooth disconnected

Ensure you are using the factory-supplied (24V 2.5A) power adapter

Type Ⅰ Type Ⅱ

Problem not solved？

Contact us:
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net
(1)Could you please take some video of the problem for us to check?
(2)Could you please provide a photo of the serial number beginning with Q on the bottom of the printer?
(3)Could you please provide a photo of your printer's test page?
(How to get printer's test page? -> Press the Feed Button and hold it until blue light flashes once, then release. Printer will
print a test page.)
(4)Your order number and the date and platform of purchase.
We will provide faster and better solutions for you.

3.3 Not compatible with iPhone / The official Bluetooth standard is

not supported

Look at the bottom of the printer to confirm the SN code:

Video(Labelife App): https://youtu.be/EEWxazbO2GI

https://youtu.be/EEWxazbO2GI


40

3.4 PC or macOS Bluetooth not supported？

1.Printing from computer with Labelife ?

Video(Labelife PC-Bluetooth): https://youtu.be/5NN0tt423dY

2.Printing from computer with Driver ?

①Windows

Video(Win-Bluetooth): https://youtu.be/pAfOsi21fGk

②macOS

Video(Mac-Bluetooth): https://youtu.be/xnsfI7qXRwo

4. Labels issues

4.1 Printer comes with a small quantity labels
Contact us for more labels
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net

4.2 Labels folded inside the printer and stuck together
Contact us for more labels
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net

4.3 Hard to position the sticker roll feed correctly / it doesn't have a

roll holder
Contact us for more label holder
Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)
Email:support@labelife.net

4.4 Printer does not print color

Thermal technology printer can only print in black and white on thermal paper, if you want more colors,

please contact us for more color labels:

Tel:+1 833-940-3818
Office Hours: Mon-Fri 9AM-5PM(US EST)

https://youtu.be/5NN0tt423dY
https://youtu.be/pAfOsi21fGk
https://youtu.be/xnsfI7qXRwo
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Email:support@labelife.net
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